Security Update | TDECU Skip to main content Skip to footer
Intermittent issues when logging in to Online/Mobile Banking. Learn more about how to access your account here. ×
Menu

Online Banking Security Update

Security improvements could affect your access to Online/Mobile Banking.
Action may be required before May 31.

Our commitment to you

TDECU is committed to protecting Member data and ensuring the safety of its communications network. Maintaining the privacy and security of your personal and private information is of paramount importance and we want to alert you about an important security change that requires your attention. Maintaining the latest browser version is important for keeping your computer secure across all websites. 

What is changing?

Browser security change - discontinued support for TLS 1.0

TDECU will be disabling the TLS 1.0 encryption protocol in favor of TLS 1.1 or higher protocols on May 31, 2018.

This means that if you are using a web browser or device that is not capable of using TLS 1.1 or higher encryption protocols to connect with our Website, Online Banking, and Mobile Banking sites you will not be able to access these sites.

You can test your TLS “score” by visiting this website and check if your browser has already disabled TLS 1.0 by visiting this website.

Please make sure that you have updated your device software and/or web browser to the latest release before May 31, 2018, to continue accessing Online Banking and Mobile Banking.

For your convenience, we have compiled a list of frequently asked questions below.

If you have any additional questions, please contact us.

Frequently asked questions

What is the TLS 1.0 protocol?

TLS stands for “Transport Layer Security.” It is a protocol that provides privacy and data integrity between two communicating applications. It’s the most widely deployed security protocol used today and is used for web browsers and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification. The versions of TLS, to date, are TLS 1.0, 1.1 and 1.2.

What is the reason for this change?

TLS aims to provide privacy and data integrity between two communicating applications. TLS 1.1 and above provide significantly higher security controls than TLS 1.0. Protecting your data is of the utmost importance for us, and this disablement will allow us to better ensure the security of your data. Our goal is to make this process as seamless as possible while maintaining the highest security standards.

I use an Android device to access my accounts. Why can't I access my mobile banking application?

Members operating on Android version KitKat (4.4) and lower, which includes about 20% of the U.S. population according to current usage patterns, may be impacted by the disablement of TLS 1.0 as these versions do not support TLS 1.1 and 1.2. Upgrading to Lollipop (5.0) or higher will fix this issue and support TLS 1.1 and 1.2 or you may download the latest Google Chrome or Firefox for Android applications from the Google Play Store.

How do I check what version of Android my device is running?

  • Open Settings
  • Tap About Phone

How do I update my device operating system?

Your phone will usually automatically notify you if you have an update. We recommend that you back up your device before you update your operating system. To manually update your device, follow the instructions below.

  • Plug in your device, as the update my drain your battery
  • Connect your device to WiFi
  • Open Settings
  • Scroll down and tap the About Device icon (on a tablet, you may need to tap the General tab at the top of the screen first)
  • Tap Software Update (or Update or System Firmware update depending on OS version) at the top of the menu
  • Tap Check for Updates
  • Tap Update. If there is an update available, this button will appear at the top of your screen
  • Tap Install (Reboot and Install, Install System Software)

If you experience an issue updating your mobile device operating system, please contact your device manufacturer or mobile carrier customer service for additional assistance.

I am using a web browser to access my accounts. Why can't I access Online Banking?

If you are seeing the "Stronger Security is Required" message you will need to upgrade your browser to support TLS 1.1 or higher protocols. The following browsers and versions are supported.

Browser Compatibility

Browser    
Google ChromeTM Version 38 or higher Free Download
Microsoft® Internet Explorer Versions 11 and higher Free Download
Microsoft® Edge All versions Free Download
Mozilla® Firefox® Version 27 and higher Free Download
Safari® for Desktop Version 7 and higher for OS X 10.9 (Mavricks) and higher (7) Free Download
Safari® for Mobile Version 5 and higher for iOS 5 and higher Free Download

How do I check what version of web browser I am running?

This is different for every browser and operating system. You can usually find out what browser version you have by going to the main menu and clicking About.

How do I update my web browser?

Updating a browser works differently for each one. See below for brief instructions for each of the browsers listed in the chart above.

Google ChromeTM:

  • Open the Google Chrome browser
  • Click the Customize and control Google Chrome button (icon has three vertical dots) in the upper right corner of the screen
  • In the drop-down menu, select Help then About Google Chrome
  • The window that appears will automatically check for updates and show you the current version of Chrome. If an update is available, there will be an option available to install it
  • You can also download the latest version of Chrome here: Free Download

Microsoft® Internet Explorer:

  • If you are regularly installing the latest Windows updates from Microsoft, you should have the latest version of Internet Explorer.
  • To turn on automatic updates, Open the Control Panel. Click on and open the Windows Update utility. In the left navigation pane, click the Check for Updates link. You can choose to install all available updates or select the updates you want to install.
  • You can also download the latest version of Internet Explorer here: Free Download

Microsoft® Edge:

  • All versions of Microsoft Edge should support TLS 1.1 or higher by default.

Mozilla® Firefox®

  • Open the Firefox browser
  • Click the Open menu button (icon has three horizontal lines) in the upper right corner of the screen
  • In that menu, click the Open Help Menu button at the bottom
  • Select About Firefox
  • The window that appears will automatically check for updates and show you the current version of Firefox. If an update is available, there will be an option available to install it.
  • You can also download the latest version of Firefox here: Free Download

Safari® for Desktop and Mobile:

  • Open the Apple menu and choose App Store
  • In the top of the window that appears, click the Updates button
  • Find Safari and click Update (or Update All to install all available updates)
  • You can also download the latest version of Safari here: Free Download

I can’t upgrade my device operating system. What do I do?

If you find that you are not able to upgrade your device operating system. Please contact your device manufacturer or mobile phone carrier customer service for assistance.